Topic: Novena no longer works with battery


I bought a Novena laptop (not the heirloom) from another forum user a while back, and have recently started using it again. I reinstalled Debian last night, and today when I unplugged it from AC, it died instantly. I investigated and discovered that the battery had been overdischarged while it was in storage, and the cells were all around or under 1 volt, so it's dead. I have a replacement 2S battery that I'd like to use, or I might just get another 3S that will work with the same connector. Regardless, back to the issue. The Senoko board no longer will pass DC from the battery Molex connector to the Novena mainboard. I've tried connecting a bench DC supply to the molex connector and supplying 12 volts (with and without also connecting a good 3S LiPo's balancing connector to the Senoko in case it was checking for the cell voltages), and it is not passing any output to the SATA connectors. I've also borrowed a known good 3S LiPo and it didn't work either. There is zero current draw through the molex connector.

So far, I've checked the diodes and MOSFETs and they all appear to be good, and I'm starting to
work through the schematic and check other components. Is there perhaps a built in safety feature on the Senoko that will disable DC output if the battery goes to 0 volts? It still functions perfectly if I plug in the AC adapter into the Senoko board.


2 (edited by phasewrap 2019-02-15 12:40:30)

Re: Novena no longer works with battery

I've done some searching and troubleshooting, and here is where I am at now.

It looks like the gas gauge has locked itself down and is reporting that it blew its protection fuse. It's completely read only, and @pelrun's novena-gg-tools utility is unable to write xob's flash dump to the chip. No combination of gg pfreset or anything else has been able to get it out of this read only state. I have also updated the Senoko firmware to the latest available (2.5rc1, iirc).

I looked in the PVT schematics and found what I believe is a mistake. On BQ20Z95DBT in … o-pvt.PDF, pin 16 (PFIN) is connected to R338 which is connected to 2.5V, and SAFE is not connected. SAFE is supposed to be the output pin which blows the safety fuse, and PFIN is supposed to sense if it is blown or intact. However on my Senoko board, SAFE is connected to R338 and PFIN is unconnected (or it disappears under the IC, I can't quite tell). I'm still confused about this.... how could this have ever worked before if PFIN was always unconnected? I have not found anyone else who reported their gas gauge blowing the safety fuse.

Regardless of that possible mistake, I have located R338 on my board and it still measures 5.1K Ohms, so it is not blown.

Here's a pic of the output of 'stats' via serial console. Sorry, I will get text here instead soon, I forgot to save my log file. I connected a known good 3S LiPo which the Senoko seems happy about besides the fuse issues. I haven't seen anywhere how to tell the Senoko board that I have a LiPo, not Lithium Ion, but I'm also not sure that really matters at this point.

I found a friend-of-a-friend who is willing to put a new BQ20Z95DBT gas gauge on my Senoko board so I can get around the read only flash, but I don't want to go down this road unless a software fix is impossible. As far as I can tell from the forums, Senoko boards (and most Novena related boards) are practically unobtanium these days.