Topic: xserver-xorg-video-armada fails on newer xserver

Heads up that I'm getting compilation failures on xorg-server-1.19.2, although the driver workes for 1.18.4.

The compilation issue looks like to comes from an API change in Xorg, around the screen's blockhandler function.  It looks like an argument was removed.  I tried fixing the declaration in common/compat-api.h but still got a bunch of warnings and an install failure.  Gonna try prodding this a bit more.

2 (edited by frostsnow 2017-04-09 06:15:55)

Re: xserver-xorg-video-armada fails on newer xserver

I seem to have fixed it!

I had to apply two patches.

The first patch comes from 'vctlabs' 'devel' branch, which updates the driver to use the 'NotifyFd' interface instead of 'AddGeneralSocket' and some related calls (IDK what they all are or what they do, just that they needed to be updated as per the Xorg server commit 'be5a513fee6cbf29ef7570e57eb0436d70fbd88c').

The second patch, which I wrote, updates the 'BlockHandler' function declarations, as they were changed in Xorg server commit '2a79be9e4dd1b6ba00b69ff40bc5257ec84d34da'.  Note that this doesn't do API checking like the previous patch and will thus probably break when compiled with older xservers.  Perhaps I can use the macro from the previous patch, but why does it specify '22' as an ABI version, shouldn't it be '19'?  I haven't looked into this.

Posting this from xorg-1.19.2, so it seems to be working.

Edit: Created pull request for you xobs, though it seems I cannot request for you to create a new branch for it: … ada/pull/3