Topic: Senoko - ridiculous cell voltages

Number of cells:    3 cells
Cell 1 voltage:     0 mV
Cell 2 voltage:     57375 mV
Cell 3 voltage:     57672 mV
Cell 4 voltage:     0 mV

Reading the Molex socket with a multimeter yields 12.09V
Reading the per-cell sense socket with a multimeter - treating the pin closest to the motherboard as 0V - yields 4.06V, 8.15V, and 12.09V.
I'm using the 3 cell battery from CrowdSupply. Have run the current senoko-update successfully and likewise perlrun's tool for resetting the gg. The rest of the output is no less peculiar. Where do I start?

ch> stats
Manufacturer:       Texas Inst.
Part name:          bq20z95
Firmware version:   0x150
Config version:     0x0
Charge FET:         off
Discharge FET:      off
State:              battery failure
Time until full:    65535 minutes
Time until empty:   65535 minutes
Chemistry:          LION
Serial number:      0x0001
Cycle count:        6
Battery health:     100%
Wake current:       disabled
Charge:             0%
Max capacity:       5015 mAh
Design capacity:    5000 mAh
Temperature:        28.6 C
Voltage:            49510 mV
Current:            0 mA
Average current:    0 mA
Target voltage:     0 mV
Target current:     0 mA
Number of cells:    3 cells
Cell 1 voltage:     0 mV
Cell 2 voltage:     57375 mV
Cell 3 voltage:     57672 mV
Cell 4 voltage:     0 mV
Charge status:      0x1
    Charging allowed?   yes
    Can suspend?        no
    Can precharge?      no
    Can maintenance?    no
    Temperature limit?  no
    Temperature limit?  no
    Can fastcharge?     no
    Pulse charging?     no
    Pulse disable CHG?  no
    Cell balancing?     no
    Precharge timeout?  no
    Fastcharge timeout? no
    Overcharge OV?      no
    Overcharge OC?      no
    Overcharge?         no
    Battery empty?      yes
Alarms:
    TERMINATE CHARGE ALARM
    TERMINATE DISCHARGE ALARM
    REMAINING CAPACITY ALARM
Charge state:
    Battery initialized
    Battery discharging/relaxing
    Battery fully discharged
No errors detected
No safety alerts
Safety status:
    Pack undervoltage condition
    Cell undervoltage condition
ch> 

Re: Senoko - ridiculous cell voltages

I did find https://www.kosagi.com/w/index.php?titl … Senoko_DVT which at least points to what to do:
- chg set 1000 126000 3000
- gg cells 3
- gg capacity 3 3000
- gg current 3000
- gg pfreset
- gg reboot
- gg it

I'm still getting >50V cell 3 voltage in stats though.

Re: Senoko - ridiculous cell voltages

It appears that disconnecting the battery (molex, then taps) and reconnecting it (taps, then molex) has allowed some sanity to return, however the discharge FET appears determined not to turn on, meaning that pulling the power supply shuts the machine down immediately, despite the battery appearing to be charged. How do I get the machine to draw power from the battery?

ch> gg dsg +
Discharge FET forced on
ch> stats
Manufacturer:       Texas Inst.
Part name:          bq20z95
Firmware version:   0x150
Config version:     0x0
Charge FET:         off
Discharge FET:      off
State:              normal discharge
Time until full:    65535 minutes
Time until empty:   65535 minutes
Chemistry:          LION
Serial number:      0x0001
Cycle count:        6
Battery health:     83%
Wake current:       disabled
Charge:             90%
Max capacity:       4149 mAh
Design capacity:    5000 mAh
Temperature:        28.0 C
Voltage:            12092 mV
Current:            0 mA
Average current:    0 mA
Target voltage:     0 mV
Target current:     0 mA
Number of cells:    3 cells
Cell 1 voltage:     4069 mV
Cell 2 voltage:     4080 mV
Cell 3 voltage:     3944 mV
Cell 4 voltage:     0 mV
Charge status:      0x0
    Charging allowed?   yes
    Can suspend?        no
    Can precharge?      no
    Can maintenance?    no
    Temperature limit?  no
    Temperature limit?  no
    Can fastcharge?     no
    Pulse charging?     no
    Pulse disable CHG?  no
    Cell balancing?     no
    Precharge timeout?  no
    Fastcharge timeout? no
    Overcharge OV?      no
    Overcharge OC?      no
    Overcharge?         no
    Battery empty?      no
Alarms:
    TERMINATE CHARGE ALARM
    TERMINATE DISCHARGE ALARM
Charge state:
    Battery initialized
    Battery discharging/relaxing
No errors detected
No safety alerts
No safety status messages
ch> 

Re: Senoko - ridiculous cell voltages

Your symptoms (unable to get the machine to draw power from the battery) seems to be like the ones I am having, see the thread here: https://www.kosagi.com/forums/viewtopic.php?id=420

I haven't tried to disconnect the battery yet, but I might try it now.
How long did you disconnect it for? Just a moment, or a longer timeframe?

Torfinn

Re: Senoko - ridiculous cell voltages

I tried disconnecting overnight (both Molex and taps) and reconnecting without apparent change. A possibly important difference my discharge FET is consistently off. I do wonder how large a cell voltage difference is appropriate.

6 (edited by tingo 2017-03-25 03:17:35)

Re: Senoko - ridiculous cell voltages

Ok. And when you reconnect a battery you do it in reverse order (taps, then molex)?
Never mind - I see now that you write "reconnect...taps, then molex" in your message.

Torfinn