Topic: Update to initramfs-tools failed?

sudo apt-get update
...
sudo apt-get upgrade
...
"Procesing triggers for initramfs-tools (0.120) ... /boot/initrd.img-3.19.0-00270-g3d69696 does not exist. Cannot update."

I ran the commands a second time, and it attempted 0 upgrades and 0 new installs. Does it not know that one/some of the updates failed?

How do I troubleshoot this? My bootloader still works, I'd just like to know I have the latest updates.

2 (edited by Sourcerer 2015-06-13 01:58:44)

Re: Update to initramfs-tools failed?

Try apt-get dist-upgrade instead of apt-get upgrade

Re: Update to initramfs-tools failed?

I was also experiencing this issue and not understanding why. For those interested in reading more, the man page for `apt-get` explains the difference between the "upgrade" command and the "dist-upgrade" command.

Re: Update to initramfs-tools failed?

This isn't anything to do with "upgrade" vs. "dist-upgrade", and your package upgrade was successful the first time it ran.

Debian assumes that your system will be booting via. an initramfs, but the standard novena distro does an embedded-style direct (non-initramfs) boot. When the new kernel is installed the system tries to update your initramfs, but this fails since there's no existing initramfs to update - this is the initial error you're seeing (the version number in the error message will be the kernel version you're upgrading *from*, not *to*). The reason you're not seeing any error when you re-run the upgrade is that there's no new kernel being installed, so the trigger that tries to update the initramfs isn't being run.

Short form: that message is a harmless, and expected, artefact of the way the standard novena boot process works.

Re: Update to initramfs-tools failed?

If you want kernel updates, ... to work correctly, I suggest you try the hook scripts which I developed for my installer:
http://www2.futureware.at/novena/hooks.tgz

The installer is available here: https://github.com/thesourcerer8/novena … -installer