Topic: Laptop did only boot once

When I first plugged my Laptop in, I was a bit surprised it started up right away, without me pressing a power-button. Apart from that it wasn't surprising to see it boot up, create user etc...

I also did a apt-get update/upgrade and after that wanted to do a reboot. Shutdown from GUI seemed okay, but the backlight of the display stayed on, and I could not turn the thing on or off again. Even unplugging didn't turn it off. It finally turned off, when I unplugged my USB-Keyboard when AC was unplugged.

From then on, it didn't boot again. When I plug in AC, backlight goes straight on, but it doesn't boot. It turns off when I unplug AC.

The console says this

U-Boot SPL 2014.10-rc3-00039-gc5efead (Oct 17 2014 - 19:41:27)
wait_for_sr_state: Arbitration lost sr=93 cr=80 state=2020
i2c_init_transfer: failed for chip 0x50 retry=0
force_idle_bus: sda=0 scl=1
force_idle_bus: failed to clear bus, sda=0 scl=1
i2c_init_transfer: give up i2c_regs=021a0000
Error reading SPD on DDR3.
Fatal DDR error 0x55

I tried to boot with battery unplugged and reflash button pressed, but it doesn't help and the console gives the same output.

Re: Laptop did only boot once

"Arbitration lost" definitely sounds like the battery board is still holding the line.

Unplug the battery from the battery board (both the main connector and the balancing taps).  Hold down the REFLASH button while you plug in AC (with the battery still disconnected).  Does that help?

That will do a complete cold start.

Re: Laptop did only boot once

I disconnected everything on the battery, held down reflash, and plugged it in. Did not help sad
Doesn' boot and still the same output on the console.

Re: Laptop did only boot once

on another note: is it normal, that I measure 0V on the battery when it is disconnected? Literally 0.05V!

Re: Laptop did only boot once

No, that means the battery is utterly dead. Looks like you're another unfortunate victim of the bug in the shipped senoko firmware.  That's probably worth contacting Crowd Supply support to get a replacement.

To get the reflash button trick to work, you have to remove all the power from the system. That means battery, AC, and perhaps any serial cable you happen to have plugged into the debug port, if it's backpowering the senoko chip.

Another thing to try is to remove senoko entirely and plug into the novena using the other power socket - unfortunately that requires a fair amount of disassembly - all the screws on both boards and the SSD, which then means removing the screen to get to some of them, and you'll need to remove the side case bezel to uncover the extra socket.

Re: Laptop did only boot once

I see exactly the same messages and behavior (although I haven't checked my battery voltage).

Unfortunately disconnecting the senoko doesn't change the behavior at all.
(and in fact removing the memory doesn't help either)

Re: Laptop did only boot once

aaand my battery is flat.

Re: Laptop did only boot once

nice to know I am not the only one for whom reset-button doesn't do anything with a disconnected battery
support wasn't of any help yet, either...

Re: Laptop did only boot once

okay, this is going to a point where I am getting pissed about the lack of support on this...

I got xobs advice here, so I tried the reflash-button on plug-in again but as posted it didn't help.
After pelruns post I contacted support, with a link to here.
It got replied with “bunnie and xobs should reply directly on the forum, have you been in touch with them yet?”. I answered summing up the contents of this thread, but didn't get a reply. Another mail this monday remains ignored so far...

Re: Laptop did only boot once

Error reading SPD on DDR3.
Fatal DDR error 0x55

sounds like a potential problem with the DDR3 RAM to me. Could you check with a different RAM module, preferrably a known-good module, and tell us, whether you get the same or a different error message?

Re: Laptop did only boot once

Hi 3ner,

I'm no expert but I had a similar issue. After my laptop working fine for about 10 days, suddenly I started getting Fatal Error 0x55 at boot.

AFAIUI, the u-boot program is unhappy with the DDR memory configuration values it is reading, or failing to read.

Have you read through this thread?

Basically there is a diagnostic version of the u-boot Secondary Program Loader (SPL) which can be used to boot a novena via the OTG USB port.

If you can get it to boot via the USB, you can then install a newer SPL which will ignore any bad SPD values.

This isn't fixing the root cause of the problem, just working around it, but it might allow you to get up and be able to further diagnose the problem.

With the info. in the above thread and some help via IRC (irc:// I was able to get running again.

Good luck!


Re: Laptop did only boot once

Just BTW, based on the original symptoms you describe e.g. "and I could not turn the thing on or off again" I could imagine there might be some issue with the Senoko battery controller board. It is connected to i2c bus 0 along with several other components i.e. the Accelerometer, the STMPE810 (touchscreen sensor), RTC, gas gauge (TI BQ20Z95) and the DDR3 SPD memory configuration. (AFAIK).

If you can get Linux up and running, then you can connect to the Senoko to find out more about its status e.g. by running something like: sudo minicom -D /dev/ttymxc3 -b 115200. Once you are connected, at the "ch>" prompt, type "stats".

Once again, good luck.