Topic: Bluetooth, no controller found

I am having trouble getting bluetooth going.  Not sure whether the problem is me or the board.  I don't seem to have a bluetooth controller running as per the following commands and lack of response:

First I tried:

root@novena01:~# bluetoothctl -a
Agent registered
[bluetooth]# list
[bluetooth]# devices
[bluetooth]# scan on
No default controller available
[bluetooth]# select
Missing controller address argument
[bluetooth]# show
No default controller available

Is there a controller address I should include in the select command?

I have also tried:

root@novena01:~# /etc/init.d/bluetooth start
[ ok ] Starting bluetooth (via systemctl): bluetooth.service.
root@novena01:~# hciconfig -a

I also tried to run " dmesg | grep hci", but I did not see any useful output from there.

The board is pretty much fresh out of the box, I've run "apt-get update", and "apt-get upgrade", there was a problem with dbus during that but after I did an "apt-get install libdbus-1-3" the upgrade seemed to run fine.

Re: Bluetooth, no controller found

Found the following in dmesg, will dig a bit with google for this patch

[    2.715533] Bluetooth: Patch file not found ar3k/AthrBT_0x11020000.dfu
[    2.715535] Bluetooth: Loading patch file failed

Re: Bluetooth, no controller found

Ok, I did the following, it seems to have cleared up the issue.  I guess this is so we don't end up with proprietary binary blobs on the system unless we install them?

sudo apt-get install firmware-atheros