Topic: Multitab not opening

Hi there,

got my NeTV today, flashed firmware 43 on it and it works out of the box - really great to play around. I have some questions:

The wiki says NeTV will start to update the control panel from github after booting. I can't see any updates being made, even after hours there's still no

/media/storage/docroot

and

/www/netvserver

still points to

 /usr/share/netvserver/docroot

. There seems to be no log about updating. How can I manually trigger the update?

Second, when I change the URL of the control panel to my own web box as described at https://kosagi.com/w/index.php?title=%2 … evelopment - how can I make that change permanent?

Third, when I try to use the Multitab feature, I get a success message but nothing happens on the screen:
Request:

http://192.168.178.xxx/bridge/?cmd=multitab&tab=1&options=load&param=http%3A%2F%2Fwww.heise.de

Answer:

<xml><status>1</status><cmd>MULTITAB</cmd><data><value>Command forwarded to NeTVBrowser</value></data></xml>

Looks like the browser successfully switches to tab 1 as I can see the small UI overlay in the bottom right corner disappearing. But no website content at all after that. How can I troubleshoot that?

And last, how can I see javascript debug console output?

Thanks a lot!

Kevin

Re: Multitab not opening

I figured out where the script to update the control panel is located (at docroot/scripts/updatecpanel.sh) and why it didn't worked - curl simply couldn't verify Github's SSL certificate. It did the update manually using:

$ export GIT_SSL_NO_VERIFY=1
$ /usr/share/netvserver/docroot/scripts/updatecpanel.sh >> /var/log/cron_updatecpanel.log

This looked ok but still doesn't show all channels/widgets. Maybe I got to reboot...? I'll try.

3 (edited by hokascha 2017-03-05 01:59:03)

Re: Multitab not opening

OK, now the cpanel update script works magically. It downloads the sources from github and installs /media/storage/docroot. There's a new problem now: The NeTVBrowser now needs 99% of CPU most of the time which makes it almost not responding. I reverted back to the original docroot files - no problems there. Is this a known bug? (btw, is this forum the right place to ask for suppport?)

Second, multitab still doesn't work at all. I can open a website using seturl command, though. But the content is constantly jumping around vertically on screen.... I am starting to lose patience with NeTV...