Topic: Activating 2d acceleration

Hi,

I've been a bit disconnected from the project this last months, i would want to ask what is the status of the open gpu drivers and if the 2d acceleration is available? ( from some posts in the forum it seems it already is) and it that case how can I activate it? it would be great to have a bit more fluid graphics wink
Thanks a lot

2 (edited by chris4795 2016-03-28 02:13:42)

Re: Activating 2d acceleration

Hello!

Yes, 2d acceleration is working!

I installed xorg-novena, xserver-xorg-video-armada, xserver-xorg-video-armada-etanviv and added this to my xorg.conf:

Section "Device"
    Identifier "novena"
    Driver "modesetting"
    Option "kmsdev" "/dev/dri/card0"
    Option "SWcursor" "true"
    BusID "platform:sys/devices/soc0/imx-drm.20/drm/card0"
EndSection

After that, try playing a video. assuming ti plays right, you have 2d acceleration working.

EDIT: With the 4.4 kernel, I don't appear to need the xorg.conf file.

Re: Activating 2d acceleration

The xorg-novena package includes an xorg.conf.d file that activates the driver.  It selects 'Driver "armada"'.  It should be in /usr/share/X11/xorg.conf.d/60-novena.conf.

I've just pushed linux-4.4, which includes a newer version of the drivers, a newer kernel, and a newer libdrm with libdrm-etnaviv.  This is still very experimental, and not stable at all yet, but the basics of 3D acceleration are well on their way too.

Re: Activating 2d acceleration

Hi guys,

It's been a while since I've been able to tinker again with my Novena. Sadly, I'm still not able to get the 2D acceleration (I got lag when moving windows around). I did updated the package repositories and upgraded them to the latest versions with no good results.

Any kind soul who can guide a beginner in the process? Thanks!

5 (edited by linob 2016-11-19 08:27:48)

Re: Activating 2d acceleration

Hi pacman,

when updating the system (via apt-get or aptitude), in case of a new kernel package you do only update the deb file. Unlike in standard Debian systems, the new kernel (with the newest 2D acceleration) is not installed. You have to copy files manually.

A good explanation with a novena kernel update is described at [1]. The instructions are good for running Debian from sd card. If you run it from a sata drive, you have to mount and copy to the sd card instead of /boot.

The 2D drivers of the current kernel 4.4 from the kosagi repo are cool. E. g. 720p videos are running now smoothly on my novena.

Hope this helps
linob

[1] http://novena-guide.readthedocs.io/en/latest/

Re: Activating 2d acceleration

Linob thank you so much! I just followed the guide, compiled the kernel and everything works perfectly now!!

7 (edited by nopsled 2017-01-10 19:21:23)

Re: Activating 2d acceleration

Hi,

$ glxinfo | grep rendering

If "Yes" 2D acceleration is enabled.

I'm also using a recent kernel

4.4.0-00160-g49d5f10

But unfortunately, its like I'm playing Doom3 on a Intel Pentium. I don't know how you can watch 720p videos but for my case I can't even watch Youtube videos.

So, is something must be done after updating the kernel ?

PS: glxgears (when not crashed) shows FPS around 40-60.

Re: Activating 2d acceleration

Hey Nopsled,

Just to clarify, have you tried watching a 720p video that you have on your hard drive versus watching something on youtube with firefox? When watching a 720p video with VLC from my local hard drive I have no problems, but I do not doubt for a second that attempting to watch a youtube video would be painful.

As a side note though, I upgraded from Debian Jessie to Stretch and installed Firefox (which is v50.1.0 versis Firefox ESR which is v45), and firefox runs a lot faster now.

9 (edited by nopsled 2017-01-13 00:28:45)

Re: Activating 2d acceleration

Hi Chris4795,

Well for sure using Youtube is a pain in the ass. But also, with a video file on my hard drive I can barely play a 720p videos (I'm using mpv).

Also, I think the general problem is the refresh rate as just browsing internet (iceweasel) is so painful. I'm using awesome as a window manager and with novena its not really fast, everything is so slow.

However, I noticed that using i3 is a little bit better but still using novena is like I'm watching a 1080p video  through streaming with a 56K modem connection.

Re: Activating 2d acceleration

Good Morning,

I know it's a dumb question but I will ask, you have xorg-novena, xserver-xorg-video-armada, xserver-xorg-video-armada-etanviv installed? and what driver is Xorg using, and what kernel version are you using?

I have used VLC when I tested, and it worked like I would expect it to.

Re: Activating 2d acceleration

Hi,

Yes I have all of this installed and I'm using the following kernel :

4.4.0-00160-g49d5f10

And xorg.conf is using armada driver.

Re: Activating 2d acceleration

Unfortunately past that I do not know. The only thing I can say is that I recently reinstalled the OS on my Novena, and that I am using the SSD for the video.

Maybe xobs could chime in?