Topic: Enabling Xorg on the laptop

Hello All,

I have hit a wall trying to get xorg to work. I had to reinstall my laptop and I am getting an error of "Screen(s) found, but none have a usable configuration." I have installed xorg-novena, xserver-xorg-video-armada, xserver-xorg-video-armada-etanviv, and I added the following to /etc/X11/xorg.conf

Section "Device"
    Identifier "novena"
    Driver "modesetting"
    Option "kmsdev" "/dev/dri/card0"
    Option "SWcursor" "true"
    BusID "platform:sys/devices/soc0/imx-drm.20/drm/card0"
EndSection

Am I missing something to get Xorg to work?

2 (edited by chris4795 2015-12-18 12:43:38)

Re: Enabling Xorg on the laptop

I have found out, I had to uncomment a couple of lines in 60-novena.conf

Section "Device"
    Identifier "novena"
    Driver "armada"
    Option "UseGPU" "true" # change to "false" to disable 2D acceleration
    Option "XvPreferOverlay" "FALSE" # FALSE enables xv acceleration

    # The next two options switch it from galcore to etnadrm mode
 #  Option "Screen" "0"
 #  Option "AccelModule" "etnadrm_gpu"
EndSection

Section "Files"
    ModulePath "/usr/lib/xorg/modules/"
    ModulePath "/usr/lib/arm-linux-gnueabihf/xorg/modules/"
EndSection

However, 2D Acceleration is not working now.

Re: Enabling Xorg on the laptop

You'll want to switch to etnadrm mode -- I had lots of trouble with galcore stability, and ended up moving to the all-open driver.  Also, make sure your kernel supports etnadrm.  Modern stock kernels do, and etnadrm should be getting pushed upstream soon.

4 (edited by chris4795 2016-01-01 01:25:49)

Re: Enabling Xorg on the laptop

Unfortunately when I tried to do that, I get an error of

armada: unable to load module "etadrm_gpu" (no hardware found, 0)

I seem to have libetnaviv, xorg-novena, xserver-xorg-video-armada, xserver-xorg-video-armada-etanviv.

Also, changing

    Option "UseGPU" "true" # change to "false" to disable 2D acceleration

to false allowed xorg to work. I am using the stock novena kernel, so i assume etnadrm is supported on it.

Re: Enabling Xorg on the laptop

I seemed to have fixed the issue. I think there was an issue where the kernel did not have the module. But reinstalling the kernel fixed it.

Thank you for the help xobs!